• You've discovered RedGuides 📕 an EverQuest multi-boxing community 🛡️🧙🗡️. We want you to play several EQ characters at once, come join us and say hello! 👋
  • IS THIS SITE UGLY? Click "RG3" at the very bottom-left of this page to change it. To dismiss this notice, click the X --->
MQ2Rez

Plugin - MQ2Rez (1 Viewer) 3.7

ChatWithThisName

⚔️🛡️🗡️
Moderator
Joined
Dec 29, 2017
RedCents
2,330¢
I rewrote MQ2Rez, changed the way it makes it's choice etc. Since the change is vast, I built this with builder and am giving people the opportunity to test it here before commiting changes to the git. Including the source with the dll for this rewrite. This copy has working safe mode, working VT (happens when you die with a /vt 3 007, which voice tells nobody "Help" should only hear on your computer, therefore Voicenotify now works. Includes the optional command on rez accepted from previous copy and I added color. When you first load the plugin it shows the current settings of the plugin as well as tells you about the /rez help command. the rez help command show you the options you can use to change things. This copy uses the INI from previous MQ2Rez so settings should persist.

Any issues with this copy should be reported to me directly so I can attempt to handle them as this isn't the official source for the plugin.
Happy hunting.
Edit: Removed the .dll file, left the .cpp
 

Attachments

Last edited:

ChatWithThisName

⚔️🛡️🗡️
Moderator
Joined
Dec 29, 2017
RedCents
2,330¢
no response on if this is working well for others. Does it appear to work better/worse etc. Could use feedback so it can be submitted or thrown in the trash.
 

Sic

The King of The @ Ping
Moderator
Joined
May 5, 2016
RedCents
13,016¢
no response on if this is working well for others. Does it appear to work better/worse etc. Could use feedback so it can be submitted or thrown in the trash.
Was working great for me. Died a metric fuck ton in strange magic before toons got banned. Ran it all that 6 hour stream
 

ChatWithThisName

⚔️🛡️🗡️
Moderator
Joined
Dec 29, 2017
RedCents
2,330¢
1559010750076.png

By design the settings are saved automatically when you change them via command.
The INIFileName is set automatically by simply logging into the game. It works the same way mq2berzerker and mq2rogue does. So the settings should be getting saved.
 

jamie75

Well-known member
Joined
Oct 28, 2005
RedCents
444¢
ok, not saving for my 7 toons toons.

i checked one toons server_name file in the release folder i see the below but not rezing. if i issue "/rez accept on" it will work until i logout and come back


Code:
[MQ2Rez]
Soundfile=C:\MQ2\Release\mq2rez.wav
Accept=on
Spawn=0
VoiceNotify=0
RezPct=96
RezDelay=0
SafeMode=0
Command Line=DISABLED


is it suppose to create ea dedicated ini file? if so that is not happening
 
Joined
Dec 2, 2018
RedCents
26¢
ok, not saving for my 7 toons toons.

i checked one toons server_name file in the release folder i see the below but not rezing. if i issue "/rez accept on" it will work until i logout and come back


Code:
[MQ2Rez]
Soundfile=C:\MQ2\Release\mq2rez.wav
Accept=on
Spawn=0
VoiceNotify=0
RezPct=96
RezDelay=0
SafeMode=0
Command Line=DISABLED


is it suppose to create ea dedicated ini file? if so that is not happening
I was running into this as well. I haven't confirmed, but when i changed Kiss to accept rez, it also seemed to fix that issue for me.
 

ChatWithThisName

⚔️🛡️🗡️
Moderator
Joined
Dec 29, 2017
RedCents
2,330¢
I've recompiled on test and confirmed it's working as intended.
@Sicprofundus mentioned to me when I talked to him just now that he can confirm that the plugin is acting the way it's intended and that KA might be turning it off. Based on @Residual 's response, it appears that is the case. Thus the issue you're experiencing appears to be external to the plugin. You may consider searching the Kissassist.mac and finding the line that /rez accept off, and commenting it out with a | at the start of that line.
 

jamie75

Well-known member
Joined
Oct 28, 2005
RedCents
444¢
I was running into this as well. I haven't confirmed, but when i changed Kiss to accept rez, it also seemed to fix that issue for me.

that seems to be what is happening, odd after all these years it just came up, i can only assume KA making changes to mq2rez must be new
 

ChatWithThisName

⚔️🛡️🗡️
Moderator
Joined
Dec 29, 2017
RedCents
2,330¢
it might not be new. You mentioned you used to have to issue a /rez save.
That isn't the case anymore after my rewrite, so it's possible the setting was just never saved before when KA did it.

It's using the server file same as it was before.
 

Knightly

Moderator
Joined
Jun 28, 2014
RedCents
8,511¢
Previously /rez accept did nothing. So it didn't matter that (if you had rez accept off in your KA ini) KISS issued a /rez accept off. With the update, that is fixed so now /rez accept on and /rez accept off function properly which means that if you have rez off in KISS, KISS will turn the plugin's rez off (which has probably always gotten saved to the ini, but never did anything).
 

jamie75

Well-known member
Joined
Oct 28, 2005
RedCents
444¢
looking over some older back up of INIs i think what happen as i had rez turned off in KA and it was using the plugin to accept rez. also i was using Mule's version up until 11.01 came out
 

ChatWithThisName

⚔️🛡️🗡️
Moderator
Joined
Dec 29, 2017
RedCents
2,330¢
I'd need more details surrounding the situation in which it was working and then suddenly it's not working to be able to troubleshoot.

servername_charactername.ini file has it's entries generated automatically. Any time you change a setting it's automatically saved to the INI and there is no longer a need to save an entry.

Your best bet is to post a copy of the section for me to see so I can ensure it's not an issue with settings.

Kissassist has a setting that disables MQ2Rez if you don't have the setting on. Which has, in the past, caused an issue. I'm unsure if that has been changed or if it remains the same.
 

morisato

Captin Obvious!
Moderator
Joined
Jun 8, 2013
RedCents
1,416¢
Love to Make a Suggestion for Pet classes often i wait a Little for my res and my mage makes a pet etc. then auto takes rez and has to start Over is it possible to code in a Suspend Pet First Then Take rez Then Unsuspend Pet? - This works! when i do it myself so it would Preserve the pet. thru the res.
@Redbot
 
Last edited:
Joined
Jun 28, 2017
RedCents
142¢
Code:
/rez loot on|off -> Toggle looting corpse when opened and when rezzed
Did the /rez loot command get removed in the rewrite? I just started playing around with MQ2Rez, so I might be missing something.
 

ChatWithThisName

⚔️🛡️🗡️
Moderator
Joined
Dec 29, 2017
RedCents
2,330¢
That's correct. It was removed at some point, the option wasn't there when I did my rewrite of it I don't believe.
Corpses haven't needed to be looted in quite some time. Not even sure where the code for looting went if this feature was needed again.

Updated the overview to reflect the correct options.
 
Last edited:
Joined
Jun 28, 2017
RedCents
142¢
That's correct. It was removed at some point, the option wasn't there when I did my rewrite of it I don't believe.
Corpses haven't needed to be looted in quite some time. Not even sure where the code for looting went if this feature was needed again.

Updated the overview to reflect the correct options.
Thanks. I had forgotten that live doesn't have this problem. I play on an emu server with the RoF2 client, which you still have to loot the items off your corpse.
 

Redbot

🖥️💖
Moderator
Joined
Oct 15, 2004
RedCents
51,185¢
Redbot updated MQ2Rez with a new update entry:

code cleanup, bug fixes, /rez silent

Reduce down to a single file.
Correct "extern" in cpp for autorezaccept.
remove unsigned __int64 and unsigned long long in favor of uint64_t
Now in SetGameState if you're at the character select and the plugin is "initialized" it will set it to false, so it will load character specific settings. Applies to switching characters error.
various if statements have had an extra line placed between them for readability.
reduced indentation in a few functions.
changed from CSidlScreenWnd* to...
Read the rest of this update entry...
 
Joined
Jun 9, 2008
RedCents
387¢
mq2rez is breaking on some toons , i have tried unloading and reloading i have checked to make sure accept is on , the only way it is fixed sometimes is to log out completely and back in ....
 

Knightly

Moderator
Joined
Jun 28, 2014
RedCents
8,511¢
Fix submitted, just waiting on code review to make sure I didn't break something. But, just to confirm, you said unloading and reloading the plugin doesn't fix it? Do you get the initialization message when you unload and reload?
 
Last edited:
Joined
Mar 24, 2017
RedCents
441¢
mq2rez is breaking on some toons , i have tried unloading and reloading i have checked to make sure accept is on , the only way it is fixed sometimes is to log out completely and back in ....
Yes, this happens to me. But it seems it is related to eq windows or something because i have scripts that start doing the same thing.
 

jdcincy

New member
Joined
May 1, 2020
RedCents
If I update the main server_character.cfg file to turn Mq2rez OFF, it overwrites back to ON next time I Load MQ2. How do I prevent that short of making the file read only?

With the corpses popping after server resets "helpful" people are doing AE rezzes in GL and I keep getting summoned back.
 
Joined
Jul 22, 2018
RedCents
4,919¢
If I update the main server_character.cfg file to turn Mq2rez OFF, it overwrites back to ON next time I Load MQ2. How do I prevent that short of making the file read only?

With the corpses popping after server resets "helpful" people are doing AE rezzes in GL and I keep getting summoned back.
In order of operations, the .cfg file executes after mq2 loads the initial wave of plugins, so you're not actually changing the behavior by using the .cfg file. Use the .cfg file to do things that are specific to that character that you wouldn't want done for other characters on startup. You have a couple options, you can edit the macroquest.ini file and set MQ2Rez=0 in the plugins section or you can edit the server_character.ini (this file is different than what you mentioned above). Find the section for MQ2Rez and set Accept=off. But also be aware that macros may alter any settings you make in this fashion if they were designed to be dependent on MQ2Rez doing it's thing. Resorting to flagging files as read-only is not a good idea.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top