• IS THIS SITE UGLY? Click "RG3" at the very bottom-left of this page to change it. To dismiss this notice, click the X --->

Problem - Help with an OhShit

Joined
Aug 7, 2015
Likes
7
RedCents
106¢
#1
I have this in my heals
Heals6=Shield Flash|35|Tap
and then this down in the OhShits
OhShit1=Shield Flash
OhShitCond1=${Me.AltAbilityReady[Shield Flash]} && ${Me.CombatState.Equal[COMBAT]} && ${Me.PctHPs} < 45


Prior to patch it was working as expected. Now it just spams the mQ2 window with
Ohshit triggered for shield flash condition is true

And I am just sitting here doing nothing. Any suggestions?
 
Joined
Jul 9, 2015
Likes
90
RedCents
494¢
#2
what you could do, if your using kiss11 is...

[DPS]
DPS1=Shield Flash|99|Cond1

[KConditions]
ConOn=1
CondSize=1
Cond1=${Me.AltAbilityReady[Shield Flash]} && ${Me.PctHPs} < 45
 
Joined
Jan 2, 2014
Likes
38
RedCents
1,073¢
#3
He isn't using kiss 11 if he is using an ohshit

Do you actually have spaces between the pcthps the lessthen and 45? I imagine that could cause the problem

Otherwise it looks ok
 
Joined
Dec 24, 2017
Likes
194
RedCents
1,367¢
#4
@eqmule Using 1004e15 and this started happening. Any ideas if something has changed?

I have this in my heals
Heals6=Shield Flash|35|Tap
and then this down in the OhShits
OhShit1=Shield Flash
OhShitCond1=${Me.AltAbilityReady[Shield Flash]} && ${Me.CombatState.Equal[COMBAT]} && ${Me.PctHPs} < 45


Prior to patch it was working as expected. Now it just spams the mQ2 window with
Ohshit triggered for shield flash condition is true

And I am just sitting here doing nothing. Any suggestions?
I noticed the same thing with Spurn Rk. II was happening.
OhShit1=Spurn Rk. II
OhShitCond1=${Me.CombatAbilityReady[Spurn Rk. II]} && ${Me.CombatState.Equal[COMBAT]}
 
Joined
Jan 2, 2014
Likes
38
RedCents
1,073¢
#5
When you are in combat and you think it's firing incorrectly , what do you get when you /echo the cond in game?

I dont see any difference between my old kiss1004e15 and the one just downloaded in the updater for the ohshit setup/oh shit sub

You could try putting the cond inside an ${If[putyourconditioninsidehere,TRUE,FALSE]} ... ie try this ${If[${Me.AltAbilityReady[Shield Flash]} && ${Me.CombatState.Equal[COMBAT]} && ${Me.PctHPs}<45,TRUE,FALSE]} and see if it still incorrectly fires for you
 
Top