Page 1 of 2 12 LastLast
Results 1 to 40 of 68

Thread: High CPU usage

  1. Top | #1

    High CPU usage

    I run 5-6 accounts with I-5 3570k and getting 98-100% CPU usage while even using wineq with Playnice on and idea why my CPU usage is so high?

  2. Top | #2
    So old and salty he grew scales Creator (click for more info)Administrator Maskoi's Avatar
    Join Date
    Sep 2005
    Posts
    10,838
    RedCents
    62,576

    Re: High CPU usage

    Try this. Turn off playnice and use mq2fps

  3. 3 users hit "Thanks" on this epic post, earning Maskoi 30 Redcents.

    minniemmee24 (03-17-2017), PMLL (04-25-2017), Slade the Magician (05-12-2017)

  4. Top | #3

    Re: High CPU usage

    I tried with out eq windows at all then I tried deleting client ini and it is still maxing out my CPU.

  5. Top | #4

    Re: High CPU usage

    do you go into task manager and under processes click each one and set affinity ? eq uses 1 core per instance of eq. and you have to manually do this every time to use all cores

  6. 2 users hit "Thanks" on this epic post, earning Akatora 20 Redcents.

    PMLL (04-25-2017), Slade the Magician (06-11-2018)

  7. Top | #5

    Re: High CPU usage

    It is preset in my ini plus I think windows 7 will auto do it also its showing all 4 core at 98 percent

  8. Top | #6

    Re: High CPU usage

    it doesnt, eq will always use 1 core.. the number in the ini is just what core it designates first..

    go through what i said and do it, and see if that helps, you are running each instance of eq on a seperate core.. which can be taxing on that specific core

    I also use win 7, and tried to edit the ini..

    try it and get back and let me know how it works out for ya

  9. 2 users hit "Thanks" on this epic post, earning Akatora 20 Redcents.

    PMLL (04-25-2017), Slade the Magician (06-11-2018)

  10. Top | #7

    Re: High CPU usage

    i try it and says access is denied

  11. Top | #8

    Re: High CPU usage

    FWIW, since the 6/27 EQ patch, I am seeing weird CPU spikes running just one instance of EQ on a PC that has never had any issues in the past. The CPU will max out every few minutes dropping frame rates to an unplayable 2-3 FPS for a minute or two then everything returns to normal 35 FPS. Very annoying and still haven't found a viable workaround. Not sure if your issues are similar but thought I'd add my experience in the hopes it helps troubleshoot the issue.

    I've messed around with affinity settings, deleted eqclient.ini and changed video settings within EQ to lower CPU load all to no avail.

  12. Top | #9

    Re: High CPU usage

    Quote Originally Posted by CodeXtrm View Post
    i try it and says access is denied
    administrator account? and you have to have EQ running to do it, if you arnt doing it that way

  13. Top | #10

    Re: High CPU usage

    I am running 5 accounts atm and I am running at no more then 22% cpu =\

  14. One user has clicked "Thanks" to reward Teichou for this post:

    Slade the Magician (06-11-2018)

  15. Top | #11

    Re: High CPU usage

    yeah, it really doesn't make any since especially with that processor. I can't figure out why it is eating so much resources. When i close all of EQ it goes down to 1%

  16. Top | #12

    Re: High CPU usage

    im normally at 11% CPU with 3 accounts, around 15-20% with 5, but i have to select affinity to turn on all cores for each account, each time i load one up.. if i dont im at 100% on each core, the whole time..

    i really do hope you tried it and it works for you

  17. Top | #13

    Re: High CPU usage

    I dont have any settings for the CPU cores...idk I got 7 accounts on now running at 25% cpu.....lots of ram being used haha

  18. Top | #14

    Re: High CPU usage

    Quote Originally Posted by teichou View Post
    I dont have any settings for the CPU cores...idk I got 7 accounts on now running at 25% cpu.....lots of ram being used haha
    its not in any settings, you actually have to manually go into task manager every time you load up eq and set affinity

  19. Top | #15

    Re: High CPU usage

    Quote Originally Posted by deltronhik View Post
    FWIW, since the 6/27 EQ patch, I am seeing weird CPU spikes running just one instance of EQ on a PC that has never had any issues in the past. The CPU will max out every few minutes dropping frame rates to an unplayable 2-3 FPS for a minute or two then everything returns to normal 35 FPS. Very annoying and still haven't found a viable workaround. Not sure if your issues are similar but thought I'd add my experience in the hopes it helps troubleshoot the issue.

    I've messed around with affinity settings, deleted eqclient.ini and changed video settings within EQ to lower CPU load all to no avail.
    I should add that I run 5 accounts on my main PC without a hiccup so thinking the 100% CPU thing is hardware specific.

  20. Top | #16

    Re: High CPU usage

    Quote Originally Posted by Akatora View Post
    its not in any settings, you actually have to manually go into task manager every time you load up eq and set affinity
    yah it seems to auto spread them out on my 6 cores...i look in the task manger and all my cores are running about the same.

  21. Top | #17

    Re: High CPU usage

    wish i would have known about mq2fps sooner... sadly that cut my cpu usage in half when i hit that on my toons tyvm masoki!! cant thank enough for this thread.

  22. Top | #18

    Re: High CPU usage

    Out of game things to do;

    Windows Defender turned off - this is computer and/or system specific..... youtube it


    Stickfigures in your eqclient.ini.......... this is mine with path, yours WILL be different.
    Find it, open it, edit it, save it.
    Name:  stick figures in game.JPG
Views: 1780
Size:  30.8 KB

    Either manually set affinity every time you load an EQ instance by using "Task Manager" under the Details tab........ or
    use "Process Lasso" by "Bitsum" to set affinity automatically for you... at https://bitsum.com/. I have it use the same three cores on all and leave one for spikes. It works. I figured it out..... so can you.

    In game;
    As you load edit preferences to as little as possible, also do this while playing in the "Options" menu.
    After a character loads I roll the wheel back and angle forward/down so I am looking at the top of the toons head. This eliminates peripheral gui demands if I am on that character.
    With MQ2EQBC running after all are loaded I run ....."Master Setup"
    Name:  Master Setup.JPG
Views: 1790
Size:  40.5 KB

    I run an Intel Core i3 dual core with 8 gig of ram ddr3...... hyperthread to quad core with these results.........
    Name:  170317.JPG
Views: 1798
Size:  56.1 KB

    When they first start, the memory runs to high 800, note the 716. After approximately five minutes running Kissassist, many thanks Maskoi, it settles to between high 70 and 110mb's.
    High 70's might be hard to believe so here is a picture........

    Name:  170311 03.JPG
Views: 1779
Size:  71.3 KB



    I run two sixer's with no merc's or two five box with a merc each. I am grinding up from zero. I have no tunes over 81. Everything is FTP even the "Process Lasso" is. I am not great at this game but I do enjoy it.

    That is it.
    As always,
    Playbetter
    Last edited by playbetter; 03-17-2017 at 10:37 PM.

  23. 13 users hit "Thanks" on this epic post, earning playbetter 130 Redcents.

    + Show/Hide list of the thanked

    Akatora (04-07-2017), brizors (05-13-2017), deltronhik (03-29-2017), eqtrader74 (04-15-2017), Eq_Dna (05-11-2017), minniemmee24 (03-18-2017), Minuteman (02-13-2018), playj (03-29-2017), runcade (03-29-2017), runordie (04-01-2017), scotsbiker (05-12-2017), Sicprofundus (08-05-2017), Slade the Magician (03-30-2017)

  24. Top | #19

    Re: High CPU usage

    under 500 per client is insane but 100MB per client oml

  25. Top | #20

    Re: High CPU usage

    Sadly, I've googled on this forum and this isn't really fixing my issue. Within the last two weeks my performance has degraded significantly. I was previously able to 12 box, now I can barely have 7 characters on this computer. Its not the video card, as my video card is only being used to about 20-30% of its max (per its software, its a Geforce 1060, so its over kill for EQ), but my processor is continuously spiking and hanging out well over the 70% mark for the majority of the time. Some accounts are running at 25 FPS, others running at 5. Stick figures on, definitely helps a lot. But I shouldn't have to run stick figures on my computer. I do use ISBoxer, and I was reading another forum here that said that it manages the CPU really well. My performance used to be amazing and this computer is only used for EQ so there are no changes, I've only updated video card drivers. Windows defender off, per this forum. No changes have been made to EQ display settings (Shadows are off)

    Is it that my ISBoxer has stopped managing my CPU? (basically not round robin'ing anymore)

    Computer specs:
    AMD FX 6300 / Asus M5A97 Motherboard
    32GB of ram
    120GB SSD (EVO 840)
    Geforce 1060 GTX 6 Gig

    ----EDIT-----
    I've observed that my last two instance of EQ that load take significantly longer to load than the others. Around 10 seconds longer. It also appears that both of these are using the same core, maybe these two and my first instance are using the same core.

  26. Top | #21

    Re: High CPU usage

    Quote Originally Posted by shakin_bakin View Post
    Sadly, I've googled on this forum and this isn't really fixing my issue. Within the last two weeks my performance has degraded significantly. I was previously able to 12 box, now I can barely have 7 characters on this computer. Its not the video card, as my video card is only being used to about 20-30% of its max (per its software, its a Geforce 1060, so its over kill for EQ), but my processor is continuously spiking and hanging out well over the 70% mark for the majority of the time. Some accounts are running at 25 FPS, others running at 5. Stick figures on, definitely helps a lot. But I shouldn't have to run stick figures on my computer. I do use ISBoxer, and I was reading another forum here that said that it manages the CPU really well. My performance used to be amazing and this computer is only used for EQ so there are no changes, I've only updated video card drivers. Windows defender off, per this forum. No changes have been made to EQ display settings (Shadows are off)

    Is it that my ISBoxer has stopped managing my CPU? (basically not round robin'ing anymore)

    Computer specs:
    AMD FX 6300 / Asus M5A97 Motherboard
    32GB of ram
    120GB SSD (EVO 840)
    Geforce 1060 GTX 6 Gig

    ----EDIT-----
    I've observed that my last two instance of EQ that load take significantly longer to load than the others. Around 10 seconds longer. It also appears that both of these are using the same core, maybe these two and my first instance are using the same core.
    Have you tried using the isboxer cpu strategy wizard and selecting "Select all cpus with every window" option? This works a lot better for me nowadays than the round robin setting.

    Also are you using mq2fps? If you are make sure you have "Mode=1" in your ini as the other option puts the load on your cpu rather than your graphics card (I think).

  27. Top | #22

    Re: High CPU usage

    playbetter, you've done an amazing job on minimizing memory usage!

    Do you know what did you change that dropped the memory usage?

    For years, I've been using stick figures, old models, small viewports(no mq2fps but /viewport 0 0 320 240), and so on all of the optimizations that I could find.

    CPU performance is good but EQ remains a memory hog on my machines.

    No matter what I do all of my characters run 500-800MB per instance each, old zones, new zones.

    EDIT: OP for high CPU usage, check what you have under Max Background FPS in Options->Advanced. Once I set it to Min. CPU my CPU usage dropped dramatically with no ill effects.

  28. 2 users hit "Thanks" on this epic post, earning playj 20 Redcents.

    Slade the Magician (03-30-2017), Zaunt (03-29-2017)

  29. Top | #23

    Re: High CPU usage

    Quote Originally Posted by playj View Post
    playbetter, you've done an amazing job on minimizing memory usage!

    Do you know what did you change that dropped the memory usage?

    For years, I've been using stick figures, old models, small viewports(no mq2fps but /viewport 0 0 320 240), and so on all of the optimizations that I could find.

    CPU performance is good but EQ remains a memory hog on my machines.

    No matter what I do all of my characters run 500-800MB per instance each, old zones, new zones.

    EDIT: OP for high CPU usage, check what you have under Max Background FPS in Options->Advanced. Once I set it to Min. CPU my CPU usage dropped dramatically with no ill effects.
    When I hyperthreaded and began setting affinity to "all...... less one" and attacked anything in game that appeared to bleed off CPU it came down. Project Lasso helped get the affinity automated at start up.

    Worth Checking
    After seeing a major decrease in efficiency I tracked it down to multiple same file contamination.


    Name:  170329 GamePath.JPG
Views: 1703
Size:  59.0 KB

    I was accessing the game from two different paths, Daybreak NEW Sony OLD. The solution was to rename the old Sony. That caused all those game file requests that were going to the old one to fail, prompting me, and identifying the problems so I could fix them in real time.



    As always,
    Playbetter

  30. 3 users hit "Thanks" on this epic post, earning playbetter 30 Redcents.

    playj (11-27-2017), shakin_bakin (04-04-2017), Slade the Magician (05-12-2017)

  31. Top | #24

    Re: High CPU usage

    Quote Originally Posted by Kellon View Post
    Have you tried using the isboxer cpu strategy wizard and selecting "Select all cpus with every window" option? This works a lot better for me nowadays than the round robin setting.

    Also are you using mq2fps? If you are make sure you have "Mode=1" in your ini as the other option puts the load on your cpu rather than your graphics card (I think).
    Hmm I'll give this a shot and get back to you! Thanks!

  32. Top | #25

    Re: High CPU usage

    Use the MQ2FPS plugin as suggested earlier, specifically the background rendering functionality. It will drastically reduce the amount of CPU usage for even the worst of the processors.

    MQ2FPS

    /render bg 3 This is usually good enough.


    From my experience CPUload doesn't really do much when you're using ISBoxer. You should always just let ISBoxer manage your CPU process balancing.

  33. Top | #26

    Re: High CPU usage

    Playbetter: I have a clean install of EQ with all files being DBG now, versus the old sony install... Sadly did not help.

    Etheral: When I put /render bg 3 , my frame rates go so slow I cant even type on them. However my processor does drop to about 60-70%

    I would like to state that, I went and bought windows 10, did a clean install, updated all drivers, the only thing loaded is EQ. I have now went back through and adjusted all my settings per this forum. I have also made sure that I didn't transfer any INI's or character files over just incase they had some settings that would of caused this.

    I have MQ2FPS on, and its always been on. I just turned off CPULoad and going to reload and restart.

    And BTW, thanks for the help. Really upset I'm having all these issues now

    - - - Updated - - -

    Quote Originally Posted by Kellon View Post
    Have you tried using the isboxer cpu strategy wizard and selecting "Select all cpus with every window" option? This works a lot better for me nowadays than the round robin setting.

    Also are you using mq2fps? If you are make sure you have "Mode=1" in your ini as the other option puts the load on your cpu rather than your graphics card (I think).
    Just tried this and it didn't help.

    Of note. I have found that I have 4-5 windows that run decent, and I always have two windows that run bad. I have a six core processor, which makes me wonder if two windows are sharing one processor. But even then, the processor shouldn't have an issue running two instances. I get frame rates around 2-5 on those two windows. The windows appear to be the second window and the last window most often, but sometimes its the first window.

  34. Top | #27

    Re: High CPU usage

    Quote Originally Posted by shakin_bakin View Post
    It also appears that both of these are using the same core, maybe these two and my first instance are using the same core.

    I read back through your posts and did not see where you set up the affinity. If you did/do please ignore this response.
    You must manage core affinity.....
    Either set affinity on each instance at startup to "all less one"
    Or get "Process Lasso" set it and forget it...

    "All less one" means set the affinity on each instance the same, cores 0 through 4 on and 5 is left off.

    Hope this helps,
    Playbetter

  35. Top | #28

    Re: High CPU usage

    Quote Originally Posted by playbetter View Post
    I read back through your posts and did not see where you set up the affinity. If you did/do please ignore this response.
    You must manage core affinity.....
    Either set affinity on each instance at startup to "all less one"
    Or get "Process Lasso" set it and forget it...

    "All less one" means set the affinity on each instance the same, cores 0 through 4 on and 5 is left off.

    Hope this helps,
    Playbetter
    I have IS Boxer which I thought meant I didn't need to set affinity. I also tried ot set affinity manually once and it didn't help. Going to try and figure out process lasso as posted in this forum and see if that works.

    - - - Updated - - -

    Quote Originally Posted by playbetter View Post
    I read back through your posts and did not see where you set up the affinity. If you did/do please ignore this response.
    You must manage core affinity.....
    Either set affinity on each instance at startup to "all less one"
    Or get "Process Lasso" set it and forget it...

    "All less one" means set the affinity on each instance the same, cores 0 through 4 on and 5 is left off.

    Hope this helps,
    Playbetter
    Ok ran Lasso. I have it set CPU affinity to 0 through 4 is on for all processors and 5 is left for spikes. My processor is pegged nearly 100% according to the lasso bars except that last window. I have tried turning VP on, ran /plugin mq2fps just to make sure it was on... did the bg 10,25 .....

    And my processor may be going down slightly to lets say 90% capacity at a minimum to all, and I still have at least two accounts that are getting 2 FPS right now and a third that is getting 4FPS..

    P.S. Thanks for the help on this. Its a pretty aggravating issue cause I cant really box

    - - - Updated - - -

    Could it be my processor is burned up or something? should I try a benchmark or something? my processor has never broke 65 degrees Celsius. I have my computer set to turn off if it hits that.

    I found the setting that says "Avoid non-physical cores" hit that button and my CPU usage dropped to about 62%.... but I'm still getting those super low frames per second... my FPS did not go up at all.. Going to try and restart after this raid.
    Last edited by shakin_bakin; 04-05-2017 at 08:46 PM. Reason: More updates

  36. Top | #29

    Re: High CPU usage

    Quote Originally Posted by shakin_bakin View Post
    I have IS Boxer which I thought meant I didn't need to set affinity. I also tried ot set affinity manually once and it didn't help. Going to try and figure out process lasso as posted in this forum and see if that works.

    - - - Updated - - -



    Ok ran Lasso. I have it set CPU affinity to 0 through 4 is on for all processors and 5 is left for spikes. My processor is pegged nearly 100% according to the lasso bars except that last window. I have tried turning VP on, ran /plugin mq2fps just to make sure it was on... did the bg 10,25 .....

    And my processor may be going down slightly to lets say 90% capacity at a minimum to all, and I still have at least two accounts that are getting 2 FPS right now and a third that is getting 4FPS..

    P.S. Thanks for the help on this. Its a pretty aggravating issue cause I cant really box
    If you are using Windows 10 open xbox app and disable the game bar. That stupid app was killing my CPU. Also remove ShadowPlay Relive any playback feature on your Graphics Card. They also kill your CPU usage.

  37. Top | #30

    Re: High CPU usage

    Quote Originally Posted by Noobhaxor View Post
    If you are using Windows 10 open xbox app and disable the game bar. That stupid app was killing my CPU. Also remove ShadowPlay Relive any playback feature on your Graphics Card. They also kill your CPU usage.
    How do I disable the game bar? I had to log into my Xbox app on this computer. I've never opened it until now.

    As far as playback features. I never even installed that stuff for my video card.

  38. Top | #31

    Re: High CPU usage

    Quote Originally Posted by shakin_bakin View Post
    How do I disable the game bar? I had to log into my Xbox app on this computer. I've never opened it until now.

    As far as playback features. I never even installed that stuff for my video card.
    Its under settings in bottom left, TURN OFF RECORDING. You can also hit "Windows Key + G" then hit the gear, untick In Game Recording and save.
    <----Don't forget to click Thanks! Author of Auto Macros

  39. Top | #32

    Re: High CPU usage

    Quote Originally Posted by Noobhaxor View Post
    Its under settings in bottom left, TURN OFF RECORDING. You can also hit "Windows Key + G" then hit the gear, untick In Game Recording and save.
    Hmm, thanks for that one. No change to my FPS.

    Its weird. At player select screen, I have 60+ FPS on 4 of 7 accounts and it sprints to 60 FPS.... but on the other two-three accounts it will only climb to 24ish... and it does it at a jog versus the sprint of the others. Its like those three are using a different graphics card or something... Its weird. The video settings are the same. I've went and checked those about three times and I made sure that it was using the same graphics card. I have two graphics cards in my computer one running the second monitor.

    **Restarted. Loaded up... still have two windows getting extremely low FPS. 2-3ish sometimes 5ish... even if I sit on them they don't go above 5.
    Last edited by shakin_bakin; 04-05-2017 at 07:25 PM.

  40. Top | #33

    Re: High CPU usage

    Quote Originally Posted by shakin_bakin View Post
    Hmm, thanks for that one. No change to my FPS.

    Its weird. At player select screen, I have 60+ FPS on 4 of 7 accounts and it sprints to 60 FPS.... but on the other two-three accounts it will only climb to 24ish... and it does it at a jog versus the sprint of the others. Its like those three are using a different graphics card or something... Its weird. The video settings are the same. I've went and checked those about three times and I made sure that it was using the same graphics card. I have two graphics cards in my computer one running the second monitor.

    **Restarted. Loaded up... still have two windows getting extremely low FPS. 2-3ish sometimes 5ish... even if I sit on them they don't go above 5.
    If you are using ISBoxer and multiple gpu's you need to read GPU Mangement: http://isboxer.com/wiki/GPU_Management

    TL;DR
    Code: 
    How to get high performance cross-monitor Swapping
    There are exactly two ways that allow you to move a window from one monitor to another without losing performance:
    Use ONE video card instead of two (Windows Vista or later only!)
    Use SLI or Crossfire mode (your mileage may vary, as described above)
    How to split the load between multiple GPUs
    In order to split the load between multiple GPUs yourself (as opposed to using SLI or Crossfire):
    Avoid using Cross-monitor Swapping (note that when swapping occurs, the same GPU handles the rendering as before, but incurs a performance hit to render on the other screen)
    Pick a Window Layout where the Home Region for each Window is on the GPU you would like to power it. That GPU will power the window for its lifetime, regardless of whether the window moves to the other screen via Cross-monitor Swapping.
    <----Don't forget to click Thanks! Author of Auto Macros

  41. One user has clicked "Thanks" to reward Noobhaxor for this post:

    MVP (04-06-2017)

  42. Top | #34

    Re: High CPU usage

    Noob,
    Thanks for the responses. I am playing on one screen. I just use the second monitor for scrolling through websites and what not. Should I disable this graphics card in the systems settings and see if that helps?
    Also, I have closed out of 3 of 7 accounts jus to see if performance would improve. And my one account is barely getting 2 FPS right now while the others that are in the same zone at the same place are pulling 15-20 pretty steadily. (this was the last account loaded) (Makes me wonder if its not a settings issue or something?)

    **Edit** Tried disabling the monitor that had no effect. Also, if this helps. I can turn and look at a wall and get away from other characters and my FPS goes up, But as soon as I look at other characters in game, my FPS plummets. (I've went as far as trying a different network card thinking it was a bandwidth issue)

  43. Top | #35

    Re: High CPU usage

    Quote Originally Posted by shakin_bakin View Post
    Noob,
    Thanks for the responses. I am playing on one screen. I just use the second monitor for scrolling through websites and what not. Should I disable this graphics card in the systems settings and see if that helps?
    Also, I have closed out of 3 of 7 accounts jus to see if performance would improve. And my one account is barely getting 2 FPS right now while the others that are in the same zone at the same place are pulling 15-20 pretty steadily. (this was the last account loaded) (Makes me wonder if its not a settings issue or something?)

    **Edit** Tried disabling the monitor that had no effect. Also, if this helps. I can turn and look at a wall and get away from other characters and my FPS goes up, But as soon as I look at other characters in game, my FPS plummets. (I've went as far as trying a different network card thinking it was a bandwidth issue)
    Load MQ2viewport and then type /vp on or if you are using EQBC /bcaa //vp on

    I have a shitty computer that I occational have to 4 box on and this plugin is a life saver. Use it for troubleshooting and see if your FPS climbs.
    <----Don't forget to click Thanks! Author of Auto Macros

  44. Top | #36

    Re: High CPU usage

    After grouping up I use the following Master Setup hot key............

    Name:  170406.JPG
Views: 1589
Size:  64.4 KB

    with the numbers shown.......


    I have substituted many numbers and combinations. This seems to work best for my old dual core 8 gig of ram machine.

    Man I hope something works for you,
    Playbetter

  45. 2 users hit "Thanks" on this epic post, earning playbetter 20 Redcents.

    playj (04-06-2017), Zaunt (04-07-2017)

  46. Top | #37

    Re: High CPU usage

    Quote Originally Posted by Noobhaxor View Post
    Load MQ2viewport and then type /vp on or if you are using EQBC /bcaa //vp on

    I have a shitty computer that I occational have to 4 box on and this plugin is a life saver. Use it for troubleshooting and see if your FPS climbs.
    Significantly helped all windows but the one receiving 4 FPS. But, doing everything you have said to include Lasso has made my processor utilization drop to about 50%... sometimes it goes as low as 30%

    - - - Updated - - -

    Quote Originally Posted by playbetter View Post
    After grouping up I use the following Master Setup hot key............

    Name:  170406.JPG
Views: 1589
Size:  64.4 KB

    with the numbers shown.......


    I have substituted many numbers and combinations. This seems to work best for my old dual core 8 gig of ram machine.

    Man I hope something works for you,
    Playbetter
    Just tried this again.. It works well on all windows but one. The one that when I load only gets like 2-4'ish FPS, does not improve at all. CPU Utilization is down to about 50%, Ram is well below half (using somewhere around 4-5 Gigs normally now on 7 accounts) That's whole computer usage...

    I just cant seem to figure out why 1 or two accounts get poor FPS, while others are hitting the max FPS limiter... I click between them using ISBoxer and I constantly am seeing 30+ FPS, then one will be 4 or something really low. I've begun pulling my ram sticks just trying to continue to trouble shoot until I find the problem. I'm open for any suggestions at this point.

    Its really weird... Like I'm sitting in Kael a nice empty zone. When I look at my characters FPS starts at 4 and climbs to say 9-10... if I turn and run away with just that one character FPS will start climbing to 40 fairly quickly... if I turn around and run back them, goes down to 10 as I get closer and is choppy the whole way back to them.. Also effected when I look at NPC's in the zone and try and run to them, similar instance. I don't know if this will help or not to someone who understands the architecture of processing power better than me or not.

    System: Have CPU down to about 40% usage now, Ram is still way below max (around 4 gigs), video card is overclocked to 104% which is standard but the GPU clock is running well under 50% of its max.. its only going up when it gets stressed which is not often.

  47. Top | #38

    Re: High CPU usage

    im going to quote what I tested for low FPS from the performance thread as I did testing over a few hours to figure out what was causing the horrible FPS

    what fixed the lag is i deleted eqclient.ini file from my eq folder *well in my case i copied my live version over to my test one* and it all went away, I do this from time to time and it fixes the horrible lag.

    I have 24 gigs of ram, GTX 1070 and a I7 OC'ed to 5 ghz and a 300 meg internet connection . no reason i should be lagging anywhere in this game with 1 instance. before doing that I would lag horribly, now after I do that I can run around anywhere with 10-18 characters up with no lag what so ever.


    I also find what causes this is when I go into the options editor to change some settings, if I leave those alone after doing this I wont get lag at all.. If i touch those settings at all i cant even load in 1 instance without sitting at 8 fps generally for 1 instance.


    update this also happens when I go into the settings in game and change the graphics around as well. Tried to turn off LOD and all spell densities and even in the advance tab turned off some stuff and it lagged me to all hell after i loaded in a new character. logged out re did the eqclient.ini and it went away.

    - - - Updated - - -

    Ok so I went through and tested all the graphic settings in the options menu in game. I tried every combination and found that if I uncheck *allow hw Vertex shaders* it causes a ton of lag, even if everything else is on.. I now have everything else off and the second I uncheck that and log back in its instant 5 fps.. im sitting at 135 fps in the lobby with 30 people next to me.

    I dont know if anyone else has had that issue but you are more than welcome to test this as well.. its worked for me

  48. Top | #39

    Re: High CPU usage

    Update: I ended up troubleshooting pieces of hardware piece by piece to start eliminating that as an option. I completely removed the other video card in my computer and have now almost completely eliminated my slow FPS. I don't know why disabling it didn't work.

    I am now under 50% CPU load and have dropped my ram usage significantly by using the above recommendations, and routinely pulling 40+FPS on active screens.

    Thank you all for the help!

  49. Top | #40

    Re: High CPU usage

    Great thread, thanks so much! I'm 6-boxing on an older laptop (Win7, quad core, 8g) and these tips let me drop from 80% cpu usage to 20-35%. Adding Sym's suggestion later also dropped memory usage to 100-200 mb per game.

    Things I've done:
    1. Added stickfigures=1 to eqclient.ini under [Default]
    2. Daybreak Launcher - Advanced Options = Turned off all Luclin models, turned off all video/sounds options
    3. Everquest - Options - Display = Sky(off)/armor(off)/clip plane 10%/all particles set to near & off
    4. Everquest - Options - Display - Advanced = Everything turned to lowest setting or un-checked except: Allow hq Vertex Shaders (on), Allow 2.0 Pixel Shaders (on), Disable Tattoos (on), Actor Clip Plane (set to middle), Max Frames per second 60
    5. Log in 6 characters. MQ2EQBC server turned on and responding.
    6. Task Manager - Processes = Manually 'Set Affinity" on processes of all eqgame.exe to CPU 0-2, leaving CPU 3 unchecked.
    7. Run my versions of playbetter's social macro for mq2fps/viewport. See macros below. All characters appear to activate mq2fps/viewport via their MQ2 window.
    8. (Removed) - See update below about Windows 7 and using Moo Window Menus Plus.



    For others messing with video settings, unchecking the Vertex Shader/Pixel Shader made my computer run 5 C degrees hotter. Per other write-ups, that option sends some graphics calculations to the CPU instead of the graphics card. Leaving those checked was better for me.

    playbetter's macro: The multiline version didn't work for me, it would send the commands but each MQ2 would report errors instead of running them. I split it into two macros with no multiline. These seem to work on all characters.

    Code: 
    /bcaa //plugin mq2fps
    /bcaa //fps on
    /bcaa //fps mode absolute
    /bcaa //maxfps fg 60
    /bcaa //maxfps bg 6
    Code: 
    /bcaa //plugin mq2viewport
    /bcaa //vp on
    Note: After setting up Viewport, you will sometimes log in and have your UI visible, bu the world is blacked out. It will correct itself after a minute or you can use this command to get the world to appear:
    HTML Code: 
    /viewport reset
    New versions of Windows seem to manage the memory usage better and will auto-reduce your EQ memory as needed. For my Windows 7 computer the Moo Window Menu Plus program that Sym shared helped out. You can force the memory reduction right after EQ loads. Here is an example of memory saving 6-boxing with Moo.

    Overall I'm very happy with the changes. Thanks to everybody who contributed to this post! I feel like I can open a browser window while multi-boxing without risking a party wipe due to the CPU slowing down.
    Last edited by eqtrader74; 06-07-2018 at 02:44 PM. Reason: Was able to also fix memory usage.

  50. 5 users hit "Thanks" on this epic post, earning eqtrader74 50 Redcents.

    Maha (08-02-2017), playbetter (06-23-2017), playj (07-24-2017), Redbot (06-04-2018), scotsbiker (06-22-2017)

Similar Threads

  1. MQ2Melee usage
    By milfman in forum Requests and Questions
    Replies: 1
    Last Post: 07-19-2009, 12:30 PM
  2. Usage of Advpath?
    By Mochila in forum Requests and Questions
    Replies: 15
    Last Post: 11-18-2005, 09:31 AM
  3. RoboBoar w/o Buff Slot Usage
    By codecaster in forum Strategies
    Replies: 8
    Last Post: 09-15-2005, 10:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •