• You've discovered RedGuides 📕 an EverQuest multi-boxing community 🛡️🧙🗡️. We want you to play several EQ characters at once, come join us and say hello! 👋
  • IS THIS SITE UGLY? Click "RG3" at the very bottom-left of this page to change it. To dismiss this notice, click the X --->

Problem - Looting issues (1 Viewer)

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
Not exactly sure what has happend, But for some reason as of the last couple days my auto looting has been messed up and Im hoping someone knows why.

For instance,
In my MQ loot configuration settings I have the following

Animal Venom=Destroy
Tainted Delphinium=Destroy
Tainted Larkspur=Destroy
Tainted Oleander=Destroy
Tainted Caladium=Destroy
Tainted Delphinium=Destroy
Tainted Muscimol=Destroy

Thats just to name a portion for example. However my toon is in fact looting items that are set to "Destroy" and keeping them in his Inventory essentially overtime cluttering the crap out of my bags.
Anyone have any idea whats goin on?
This wasnt an issue a week ago

Thanks
 
Joined
Mar 15, 2016
RedCents
3,693¢
Are you using mq2autoloot? If so you need to click the loot settings button on your advanced loot window and then uncheck "Auto Loot All" .

The next version will do this automatically for you, or you could set your items to ignore if you don't mind the corpses.
 

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
Does that also effect NINJADVLOOT?
I dont recall changing that setting. But it is in fact checked to autoloot all

- - - Updated - - -

Also, Ive noticed alot lately, items are getting stuck Queing to personal list. And it just stops Kissassist from continuing and spams
MQ2 NINJADVLOOT : Shared list: "item" is marked Sell. Que item to personal list
But it never completes
 
Joined
Mar 15, 2016
RedCents
3,693¢
Sorry, I have no idea about ninjadvloot. I haven't used it in 4 or 5 months at this point. Hoosierbilly would be the one to ask about that.

I would do a find and replace in your loot.ini setting all your items marked destroy to ignore.

If your having problems with ninjadvloot you could load mq2autoloot and turn looting off in kissassist and see how that works for you. But, first make sure to uncheck Auto Loot All.
 
Joined
Feb 6, 2007
RedCents
1,193¢
I will need a few days before I can do any troubleshooting of ninjadvloot. If this started with the latest compile it is possibly an issue with mq2 rather then the macro itself.
Kinda hate to admit it but the plugin is much faster then the macro and I agree with Plure give the plugin a try and see if the problem goes away.
 

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
I did load up Mq2autoloot.
It is working but i also have encountered a similar error. It spams out MQ2autoloot SList Giving "Item" To me
just getting stuck in that loop. at that point i cannot manually give or loot item, and usually i have to log to character select and back in for it to clear
 
Joined
Mar 15, 2016
RedCents
3,693¢
Did it happen for every item you were trying to loot, one specific item, or just randomly? What is your typical ping meter reading when this is happening? I noticed I had a similar issue pop up when my ping went too high, though it didn't lock me out from looting an item it just attempted to loot it multiple times before succeeding.
 

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
Did not happen on every item, It seemed it was only 1 or 2 items that would get stuck..
So when advloot window was up i could assign CERTAIN loots but then the first or second would tell me "Cannot perform that action"

I also saw a message that i forgot to Screenshot that said something like... WHOA BILLY! yada yada yada yada
But mostly just saw spam message for looting
I also am curious, Could it possibly have anything to do with putting group into raid format with my alts, and switching raid options to let entire raid loot? Could that cause any conflict?

- - - Updated - - -

This is one of the errors im getting, and it Death loops and Kissassist wont continue while its spamming loot message at me.
Mind you i was using MQ2autoloot at the time this popped up.

- - - Updated - - -

Here is the other Death loop of looting im experiencing, and i rechecked my Ini. Since i turned on MQ2autoloot, my loot=0
 

Attachments

Joined
Mar 15, 2016
RedCents
3,693¢
I have never tested it while in a raid, does the problem persist if you are just in a regular group?

When i am getting a bit of lag it has spammed that message at me a couple times, i haven't seen it since i adjusted the delays a bit. I sent you that version in the pm, is the problem still happening with that version?

Mq2autoloot by itself shouldn't lock up KA, it will spam your mq2 chat window at worst. It appears both ninjadvloot and mq2autoloot are running at the same time, i suspect ninjadvloot is the one locking KA.
 

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
Yes i did experience the same loop in group format.
I do suspect something went wrong somewhere in my loot files. I noticed some items that i have set to Random are being ignored completely and other items that should have been looted are being left on corpse.
In turn that makes me think the reason i havent seen a EOK chase loot in quite the long time could be due to W/E is buggy in my files.
 
Joined
Mar 15, 2016
RedCents
3,693¢
You could start a new loot file and see if the issue persists, but that shouldn't be the problem it is getting a positive loot entry for that item and attempting to loot it. Did you still have the problem with the latest version of the plugin I sent you? Also, do you have loot filters set for those 1 or 2 items that are causing issues?
 

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
I loaded the File you sent yes still had issue after the fact.I Know that I dont have any filters set for definitly 1 of the 2 items
 
Joined
Mar 15, 2016
RedCents
3,693¢
I doubt this will help, but delete those 2 entries that are causing you problem or start a new loot.ini and see if that fixes the issue. I will dig through the code to see if there is some spot that could cause a failure and sometime this weekend I'll load up both ninjadvloot along with mq2autoloot and see if there is some issue with both running at the same time.
 
Joined
Feb 6, 2007
RedCents
1,193¢
Couple of observations:

1. kissassist is NOT currently setup to make full use of ninjadvloot. You need to make a small modification to kissassist to ensure items are properly passed out to all group members. Failure to make this change will result in lore, nodrop, or =quest flagged items to be left on the corpse.

find this code
Rich (BB code):
| -------------------------------------------------------------------------------------
| Main Loop
| -------------------------------------------------------------------------------------
        :MainLoop
            /doevents
replace it with this code
Rich (BB code):
| -------------------------------------------------------------------------------------
| Main Loop
| -------------------------------------------------------------------------------------
        :MainLoop
            /doevents
	    /if ((${AdvLoot.SCount}||${AdvLoot.PCount}) && !${LootTimer}) /call UseAdvLoot

2. The error **hold your horses**... is the result of issuing a loot command before a loot action was completed. The root cause is usually lag, or another way of saying it is the macro is reacting faster then the EQ server. That error has never stopped or locked up anything, it is a warning to avoid spamming the EQ server.

3. I would avoid using both ninjadvloot and mq2autoloot. The plugin will react much faster than any macro and the macro will waste time attempting to process items that are no longer there.

4. ninjadvloot is coded for groups and uses the groups masterlooter to process the shared list. Each group member then processes their individual personal list. I will have to set up a raid and see what happens.


Now for some game time to see if I can reproduce the problem with items not being destroyed.
 
Joined
Mar 15, 2016
RedCents
3,693¢
I've only seen the plugin spam at an item more then once when i have been lagging. But that this only happens with a couple of items seems weird, like there is something preventing you from looting the item though it keeps trying to do that. That it is diamonds is weird, they are just regular old loot.
 

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
I agree its strange. Especially because its never had an issue until recently. It has run perfect for about 6 months.
Ive noticed 3 items that have caused issue, and its totally random. Sometimes no issue but when it does happen it never corrects. Just death loops the attempt to distribute.
So far its only been Diamond, Blue Diamond, and Cloth bolt
 
Joined
Feb 6, 2007
RedCents
1,193¢
Yesterday I ran first with just ninjadvloot then loaded mq2autoloot and ran both. I encountered no problems looting, bah.

open your in game advloot window and search for the advloot filters for the items you are having issue with. If you have the item filtered 'never' it will prevent looting the item. ninjadvloot is suppose to assign items filtered never to autoroll, if everyone in group has the item filtered never it should be ignored and left on the corpse.

When the death loop starts, is your advloot window open? If so are you able to see how the item is being marked in the window; need, greed, never, autoroll? And mostly is the item changing it's need/greed/never flag? It might happen too fast to see with the plugin running.
 

Trax540

Member
Joined
Feb 17, 2017
RedCents
521¢
I can say for sure, the Adv window is open when it happens. In the event of the Diamond and Blue Diamond those two have no filters selected and Autoloot usually just gives them to me being assigned master looter.
As for the Cloth Bolt that is set to Never.
 
Joined
Apr 23, 2018
RedCents
141¢
I hate to necro a thread, however this just started happening to me as well. I have looting off inside KA, I have the loot all option turned off in the games advl system and I have no filters setup. I had to switch the items from destroy to ignore and this at least keeps my bags from cluttering. However, it leaves too many corpses on the ground.

Any help would be greatly appreciated.

Thank you,
 
Joined
Mar 15, 2016
RedCents
3,693¢
I hate to necro a thread, however this just started happening to me as well. I have looting off inside KA, I have the loot all option turned off in the games advl system and I have no filters setup. I had to switch the items from destroy to ignore and this at least keeps my bags from cluttering. However, it leaves too many corpses on the ground.

Any help would be greatly appreciated.

Thank you,
I just want to confirm, items marked destroy are being looted and not being destroyed?

I vaguely remember your playing on the test server, is this correct?
 
Joined
Apr 23, 2018
RedCents
141¢
I just want to confirm, items marked destroy are being looted and not being destroyed?

I vaguely remember your playing on the test server, is this correct?
Correct, however since the Test version is not working, this is currently happening on LIVE server. It seems to only happen on certain items. I know one of them is a NO DROP item, the other isn't. I just moved camps and it is working just fine with the items available/dropping at new camp. Very weird.
 
Joined
Mar 15, 2016
RedCents
3,693¢
Correct, however since the Test version is not working, this is currently happening on LIVE server. It seems to only happen on certain items. I know one of them is a NO DROP item, the other isn't. I just moved camps and it is working just fine with the items available/dropping at new camp. Very weird.
If it is only a few specific items. I'd manually delete that entry for your loot.ini and then recreate it and see if that fixes it.
 
Joined
Jul 15, 2019
RedCents
161¢
Sorry, I have no idea about ninjadvloot. I haven't used it in 4 or 5 months at this point. Hoosierbilly would be the one to ask about that.

I would do a find and replace in your loot.ini setting all your items marked destroy to ignore.

If your having problems with ninjadvloot you could load mq2autoloot and turn looting off in kissassist and see how that works for you. But, first make sure to uncheck Auto Loot All.
I know this is a bit of an old thread but this is the only spot I found where people were talking about the setting Auto Loot All. Why, why, why would you want that unchecked? Things rot when that is unchecked and you don't notice. Can someone please explain this? I manually go in and check that box as I have had some real nice things rot on me.
 
Joined
Jul 22, 2018
RedCents
4,912¢
I know this is a bit of an old thread but this is the only spot I found where people were talking about the setting Auto Loot All. Why, why, why would you want that unchecked? Things rot when that is unchecked and you don't notice. Can someone please explain this? I manually go in and check that box as I have had some real nice things rot on me.
there are some edge cases. Imagine the scenario where you have stackable NOTRADE, non-lore items, such as quest items, that need to be handed out to multiple toons. EQ's advanced loot will not split stacks, so the character that wins the roll will get the entire stack. If he Auto Loots All, you won't have the chance to correct the mistake. There are others too, but again, they're edge cases.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top