• You've discovered RedGuides 📕 an EverQuest multi-boxing community 🛡️🧙🗡️. We want you to play several EQ characters at once, come join us and say hello! 👋
  • IS THIS SITE UGLY? Click "RG3" at the very bottom-left of this page to change it. To dismiss this notice, click the X --->

Problem - Looking for help debugging a zoning / freezing issue (1 Viewer)

Joined
Sep 16, 2020
RedCents
514¢
I have many different accounts that I log into with MQ, but I have one account that always loads zones (or graphics) very slowly. For this one account, the character loads into the zone (I can see the zone textures when the character loads), and then the character freezes for up for as long as two minutes. The account that freezes is a Silver account and is my original EQ account from 20 some years ago (probably unrelated). All the other accounts are newer accounts (<2yrs old).

I'm kind of at a loss for how to debug this. All the account use the standard EQ UI, and standard UI settings. All have frame limiting activated. I can't see any difference in how this one account is loading the screen / graphics, but clearly something is different. One other piece of info ... I loaded characters in the 'bad' account into EQ without MQ running, and and they seemed to load normally without the screen freezing issue.

Does anyone have any suggestions on how to debug this? I've pretty much stopped using characters on this account because the loading is so slow that it drives me crazy. I don't ever want to leave a zone once it's loaded.
 
Joined
Aug 19, 2020
RedCents
3,876¢
Maybe not connected, but they (DBG) did mention a few months back that when loading/zoning all your "stuff" associated with that account had to be index? (right word?). Wondering if that account is the guild owner, TS account, quest items from 2002 in the bank people, its somehow tied to that?
 
Joined
Jul 9, 2015
RedCents
1,099¢
I had one account that was always loading like crap. Turns out it was PEBKAC again. My autologin was calling the wrong eq folder for that account and trying to use the default install on the physical drive instead of the SSD. Life is hard.
 
Joined
Sep 16, 2020
RedCents
514¢
Maybe not connected, but they (DBG) did mention a few months back that when loading/zoning all your "stuff" associated with that account had to be index? (right word?). Wondering if that account is the guild owner, TS account, quest items from 2002 in the bank people, its somehow tied to that?
The account is definitely a guild owner, has lots of TS items, and a few old quest items. I've wondered if that's the problem, but I'm not sure how I would re-index the information about all that stuff in the account. Is there a local database that I could rebuild the indexes on? Anyone know?
 
Joined
Sep 16, 2020
RedCents
514¢
I had one account that was always loading like crap. Turns out it was PEBKAC again. My autologin was calling the wrong eq folder for that account and trying to use the default install on the physical drive instead of the SSD. Life is hard.
I'll look into this. I haven't ever really done much with autologin (other than use it), but I'm willing to admit it could be an ID10T error with something I've configured.
 
Joined
Aug 12, 2018
RedCents
3,280¢
The account is definitely a guild owner, has lots of TS items, and a few old quest items. I've wondered if that's the problem, but I'm not sure how I would re-index the information about all that stuff in the account. Is there a local database that I could rebuild the indexes on? Anyone know?
The CL or Dev over there (I forget which said it caused lag) advised to just move everything off your character so it does not show up in find or in your house that you own.

So I am always one to run tests on that kind of stuff. I moved all items in that character's houses to houses he did not own, moved all bank stuff to alts and basically left him with 2 bags of stuff on him. Even moved all his plat off him.

No difference in lag. None at all. Oh but wait, I never had lag to begin with. So I kinda knew there advice was wrong as I had 3 houses full, bank, dragon hoard etc all were full and there was not the lag players were complaining about.

But since the last patch I have lag. Big time. And EQ is using way more of my computer resources than what it used to.

And I have not heard anyone saying that advice worked for them either
 
Joined
Sep 16, 2020
RedCents
514¢
I had one account that was always loading like crap. Turns out it was PEBKAC again. My autologin was calling the wrong eq folder for that account and trying to use the default install on the physical drive instead of the SSD. Life is hard.
I looked at that mq2autologin.ini and it's using the correct folder. It's the same folder as any of the other accounts that load perfectly. Grrr.

The CL or Dev over there (I forget which said it caused lag) advised to just move everything off your character so it does not show up in find or in your house that you own.

So I am always one to run tests on that kind of stuff. I moved all items in that character's houses to houses he did not own, moved all bank stuff to alts and basically left him with 2 bags of stuff on him. Even moved all his plat off him.

No difference in lag. None at all. Oh but wait, I never had lag to begin with. So I kinda knew there advice was wrong as I had 3 houses full, bank, dragon hoard etc all were full and there was not the lag players were complaining about.

But since the last patch I have lag. Big time. And EQ is using way more of my computer resources than what it used to.

And I have not heard anyone saying that advice worked for them either
Thanks for testing that out, lol. What a pain in the arse that must have been to test. I guess I won't try that approach unless I get really desperate. The amount of time to move everything around would probably make me delete the account first ....
 
Last edited:
Joined
Sep 16, 2020
RedCents
514¢
So, I found a logfile dbt.txt in my Everquest install. During the load process I see a couple of errors. Maybe someone will have an idea from this info:

First error:
[Sun Jul 31 17:01:59 2022]00609:Bad file: bazaar_chr.txt
Note: This file just has a zero in it when I open it.

Second Error:
[Sun Jul 31 17:02:10 2022]00661:Memory: Load: 55, Total Phys: 16238, Avail Phys: 7228, Total Page: 32722, Avail Page: 7467, Total Virtual: 134217727, Avail Virtual: 134211939, FreeBlocks: 131349686,2017281,798720,13721,6322,2047,1977,1021,730,472
[Sun Jul 31 17:02:10 2022]00662:MaxTextures: 45826k, CurrentTextures: 44304k, HighQualityTextures: 38192k
[Sun Jul 31 17:02:11 2022]00192:D3DXCreateTextureFromFileEx()    failed to create texture electricg.dds    for    particle system.

[Sun Jul 31 17:02:11 2022]00193:D3DXCreateTextureFromFileEx()    failed to create texture electricg.dds    for    particle system.
This texture file is not found when I search the EQ installation.

Here's the complete log during the character load. After Initialization complete it took 42 extra seconds to unfreeze the screen. I have no idea why it would have a problem with a specific texture on a single character.

Complete log:
[Sun Jul 31 17:01:47 2022]00583:Starting char select.

[Sun Jul 31 17:01:47 2022]00584:Clearing display buffers.

[Sun Jul 31 17:01:47 2022]00585:Display buffers cleared.

[Sun Jul 31 17:01:47 2022]00586:Initializing character select UI.
[Sun Jul 31 17:01:47 2022]00587:Resetting game UI.
[Sun Jul 31 17:01:47 2022]00588:Initializing keypress handler.
[Sun Jul 31 17:01:53 2022]01303:knockout 3
[Sun Jul 31 17:01:53 2022]01300:knockout 3
[Sun Jul 31 17:01:54 2022]00589:Zone Connect -- 0 -- Received MSG_ZONE_ADDRESS
[Sun Jul 31 17:01:54 2022]00590:Zone addr [eqzone-79.everquest.com:1801] received...
[Sun Jul 31 17:01:54 2022]00591:ZONING
[Sun Jul 31 17:01:54 2022]00592:Networking: Connection Closed [0] with 0 pending bytes.
[Sun Jul 31 17:01:54 2022]00593:Networking: using port [54613].
[Sun Jul 31 17:01:54 2022]00594:Networking: Connection Established [1]
[Sun Jul 31 17:01:55 2022]00595:Connected to eqzone-79.everquest.com:1801...

[Sun Jul 31 17:01:55 2022]00596:Zone Connect -- 2 -- Sending MSG_EQ_ADDPLAYER
[Sun Jul 31 17:01:55 2022]00597:Zone Connect -- 3 -- Received MSG_SEND_PC
[Sun Jul 31 17:01:56 2022]00598:Received our Player from zone.
[Sun Jul 31 17:01:56 2022]00599:Received MSG_EQ_ADDPLAYER, Player = xxxxxx, zone = The Bazaar
[Sun Jul 31 17:01:56 2022]00600:MSG_TIME_STAMP received.
[Sun Jul 31 17:01:56 2022]00601:MSG_TIME_STAMP received. (Items inc).
[Sun Jul 31 17:01:58 2022]01304:knockout 3
[Sun Jul 31 17:01:58 2022]01301:knockout 3
[Sun Jul 31 17:01:58 2022]00602:Item done, MSG_WEATHER_EVENT received.

[Sun Jul 31 17:01:58 2022]00603:Initializing zone.
[Sun Jul 31 17:01:58 2022]00604:Initializing world.
[Sun Jul 31 17:01:58 2022]00184:Beginning handling memory on zoning.
[Sun Jul 31 17:01:58 2022]00185:Memory: Load: 52, Total Phys: 16238, Avail Phys: 7675, Total Page: 32722, Avail Page: 7918, Total Virtual: 134217727, Avail Virtual: 134212343, FreeBlocks: 131349686,2017281,798720,13721,6322,2047,1977,1021,730,684
[Sun Jul 31 17:01:58 2022]00186:Pools: Temp: 131072(0). Persistent: 53182648(53047682). OnDemand: 131072(71308). Zone: 0(0)
[Sun Jul 31 17:01:58 2022]00187:MaxTextures: 12887k, CurrentTextures: 2711k, HighQualityTextures: 2711k
[Sun Jul 31 17:01:58 2022]00188:Finished handling memory on zoning.
[Sun Jul 31 17:01:58 2022]00189:Memory: Load: 52, Total Phys: 16238, Avail Phys: 7675, Total Page: 32722, Avail Page: 7918, Total Virtual: 134217727, Avail Virtual: 134212343, FreeBlocks: 131349686,2017281,798720,13721,6322,2047,1977,1021,730,684
[Sun Jul 31 17:01:58 2022]00190:Pools: Temp: 131072(0). Persistent: 53182648(53047682). OnDemand: 0(0). Zone: 0(0)
[Sun Jul 31 17:01:58 2022]00191:MaxTextures: 12887k, CurrentTextures: 1216k, HighQualityTextures: 1216k
[Sun Jul 31 17:01:58 2022]00605:Verifying world files.
[Sun Jul 31 17:01:58 2022]00606:Attempting to load bazaar.EQG.
[Sun Jul 31 17:01:59 2022]00607:Loaded bazaar.EQG.
[Sun Jul 31 17:01:59 2022]00608:Loading zone specific files.
[Sun Jul 31 17:01:59 2022]00609:Bad file: bazaar_chr.txt
[Sun Jul 31 17:01:59 2022]00610:Initializing cameras.
[Sun Jul 31 17:01:59 2022]00611:Initializing lights.
[Sun Jul 31 17:01:59 2022]00612:Initializing visual effects.
[Sun Jul 31 17:01:59 2022]00613:Initializing target indicator.
[Sun Jul 31 17:01:59 2022]00614:Initializing player path.
[Sun Jul 31 17:01:59 2022]00615:Performing post-load operations.
[Sun Jul 31 17:01:59 2022]00616:Initializing precipitation system.
[Sun Jul 31 17:01:59 2022]00617:World initialized: bazaar
[Sun Jul 31 17:01:59 2022]00618:Resetting cameras.
[Sun Jul 31 17:01:59 2022]00619:Resetting overlays.
[Sun Jul 31 17:01:59 2022]00620:Zone initialized.
[Sun Jul 31 17:01:59 2022]00621:Creating INI files.
[Sun Jul 31 17:01:59 2022]00622:Requesting AA data.
[Sun Jul 31 17:01:59 2022]00623:Requesting Skill rank data.
[Sun Jul 31 17:01:59 2022]00624:Loading UI.
[Sun Jul 31 17:01:59 2022]00625:Deactivating previous UI.
[Sun Jul 31 17:01:59 2022]00626:Unloading previous textures.
[Sun Jul 31 17:01:59 2022]00627:Resetting UI.
[Sun Jul 31 17:01:59 2022]00628:Resetting character select UI.
[Sun Jul 31 17:02:00 2022]00629:Resetting game UI.
[Sun Jul 31 17:02:00 2022]00630:UI Reset.
[Sun Jul 31 17:02:00 2022]00631:Initializing UI.
[Sun Jul 31 17:02:00 2022]00632:Initializing UI manager.
[Sun Jul 31 17:02:00 2022]00633:Initializing fonts.
[Sun Jul 31 17:02:00 2022]00634:Parsing UI XML.
[Sun Jul 31 17:02:01 2022]00635:Loading default UI resources.
[Sun Jul 31 17:02:01 2022]00636:Initializing game UI.
[Sun Jul 31 17:02:01 2022]00637:Loading Icons.
[Sun Jul 31 17:02:03 2022]00638:Resetting viewport.
[Sun Jul 31 17:02:03 2022]00639:Game UI Initialized.
[Sun Jul 31 17:02:03 2022]00640:Loading UI Complete.
[Sun Jul 31 17:02:03 2022]00641:Memory: Load: 53, Total Phys: 16238, Avail Phys: 7472, Total Page: 32722, Avail Page: 7706, Total Virtual: 134217727, Avail Virtual: 134212163, FreeBlocks: 131349686,2017281,798720,13721,6322,2047,1977,1021,730,693
[Sun Jul 31 17:02:03 2022]00642:Pools: Temp: 0(0). Persistent: 53182648(53047682). OnDemand: 0(0). Zone: 8975908(8816893)
[Sun Jul 31 17:02:03 2022]00643:MaxTextures: 36792k, CurrentTextures: 36792k, HighQualityTextures: 36792k
[Sun Jul 31 17:02:03 2022]00644:Entering main loop.
[Sun Jul 31 17:02:03 2022]00645:DoMainLoop - Just after packet processing()
[Sun Jul 31 17:02:04 2022]01305:knockout 3
[Sun Jul 31 17:02:04 2022]01302:knockout 3
[Sun Jul 31 17:02:06 2022]00646:DoMainLoop - Just after actor creation()
[Sun Jul 31 17:02:06 2022]00647:Loading game sounds.
[Sun Jul 31 17:02:06 2022]00648:Requesting initialization data.
[Sun Jul 31 17:02:06 2022]00649:DoMainLoop: just before first while(!EverQuest.ReceievedWorldObjects).
[Sun Jul 31 17:02:06 2022]00650:Zone Connect -- Received MSG_SND_WOBJECTS_RESPONSE
[Sun Jul 31 17:02:06 2022]00651:DoMainLoop: complete after first while(!EverQuest.ReceievedWorldObjects).
[Sun Jul 31 17:02:06 2022]00652:DoMainLoop: just before second while(!ReadyEnterWorld).
[Sun Jul 31 17:02:06 2022]00653:Zone Connect -- Sending out a MSG_READY_ENTER_WORLD.
[Sun Jul 31 17:02:07 2022]00654:Zone Connect -- Received MSG_READY_ENTER_WORLD
[Sun Jul 31 17:02:07 2022]01306:knockout 3
[Sun Jul 31 17:02:07 2022]01303:knockout 3
[Sun Jul 31 17:02:07 2022]00655:DoMainLoop: completed second while(!ReadyEnterWorld).
[Sun Jul 31 17:02:07 2022]00656:Setting up models.
[Sun Jul 31 17:02:07 2022]00657:Starting pre-load

[Sun Jul 31 17:02:09 2022]01307:knockout 3
[Sun Jul 31 17:02:09 2022]01304:knockout 3
[Sun Jul 31 17:02:10 2022]00658:Setting up character.
[Sun Jul 31 17:02:10 2022]00659:Activating music.
[Sun Jul 31 17:02:10 2022]00660:Initialization complete.
Entering main loop.
[Sun Jul 31 17:02:10 2022]00661:Memory: Load: 55, Total Phys: 16238, Avail Phys: 7228, Total Page: 32722, Avail Page: 7467, Total Virtual: 134217727, Avail Virtual: 134211939, FreeBlocks: 131349686,2017281,798720,13721,6322,2047,1977,1021,730,472
[Sun Jul 31 17:02:10 2022]00662:MaxTextures: 45826k, CurrentTextures: 44304k, HighQualityTextures: 38192k
[Sun Jul 31 17:02:11 2022]00192:D3DXCreateTextureFromFileEx()    failed to create texture electricg.dds    for    particle system.

[Sun Jul 31 17:02:11 2022]00193:D3DXCreateTextureFromFileEx()    failed to create texture electricg.dds    for    particle system.

[Sun Jul 31 17:02:11 2022]01308:knockout 3
[Sun Jul 31 17:02:11 2022]01305:knockout 3
[Sun Jul 31 17:02:16 2022]01309:knockout 3
[Sun Jul 31 17:02:17 2022]01306:knockout 3
[Sun Jul 31 17:02:17 2022]01307:knockout 3
[Sun Jul 31 17:02:17 2022]01310:knockout 3
[Sun Jul 31 17:02:22 2022]01308:knockout 3
[Sun Jul 31 17:02:22 2022]01311:knockout 3
[Sun Jul 31 17:02:22 2022]01309:knockout 3
[Sun Jul 31 17:02:22 2022]01312:knockout 3
[Sun Jul 31 17:02:37 2022]00824:knockout 3
[Sun Jul 31 17:02:37 2022]00826:knockout 3
[Sun Jul 31 17:02:37 2022]00824:knockout 3
[Sun Jul 31 17:02:37 2022]00824:knockout 3
[Sun Jul 31 17:02:37 2022]00824:knockout 3
[Sun Jul 31 17:02:37 2022]00824:knockout 3
[Sun Jul 31 17:02:38 2022]00825:knockout 3
[Sun Jul 31 17:02:38 2022]00825:knockout 3
[Sun Jul 31 17:02:38 2022]00825:knockout 3
[Sun Jul 31 17:02:38 2022]00825:knockout 3
[Sun Jul 31 17:02:38 2022]00827:knockout 3
[Sun Jul 31 17:02:38 2022]00825:knockout 3
[Sun Jul 31 17:02:40 2022]01313:knockout 3
[Sun Jul 31 17:02:40 2022]01310:knockout 3
[Sun Jul 31 17:02:41 2022]01314:knockout 3
[Sun Jul 31 17:02:41 2022]01311:knockout 3
[Sun Jul 31 17:02:44 2022]01312:knockout 3
[Sun Jul 31 17:02:44 2022]01315:knockout 3
[Sun Jul 31 17:02:48 2022]01313:knockout 3
[Sun Jul 31 17:02:48 2022]01316:knockout 3
[Sun Jul 31 17:02:52 2022]01314:knockout 3
[Sun Jul 31 17:02:52 2022]01317:knockout 3
 
Joined
Jul 9, 2015
RedCents
1,099¢
I've checked 5 different client versions and can't find a file "electricg.dds" in any of them. To my layperson self, it looks like it's hung waiting for this file to generate, but why is that not effecting any other account? Are all the accounts using the same client folder?

I would start with copying the Character_Server.ini file out of the eq client folder to keep as a backup, then delete it in the eq folder. I don't think there are settings about particles in that ini, but there are some with sound and what not. Might not hurt to do the same with the UI_Character_server.ini file as well.

Best of luck.
 
Joined
Sep 16, 2020
RedCents
514¢
Free blocks??? Weird. Did you already try a fresh install of EQ just for this account?
I haven't tried that yet. Before I looked at this log, I assumed that since the other accounts loaded normally on the same install, that it must be a config issue. I might have to try a fresh install just to eliminate confounding variables.

I've checked 5 different client versions and can't find a file "electricg.dds" in any of them. To my layperson self, it looks like it's hung waiting for this file to generate, but why is that not effecting any other account? Are all the accounts using the same client folder?

I would start with copying the Character_Server.ini file out of the eq client folder to keep as a backup, then delete it in the eq folder. I don't think there are settings about particles in that ini, but there are some with sound and what not. Might not hurt to do the same with the UI_Character_server.ini file as well.

Best of luck.
Yes, all other accounts use the same client folder.

Free blocks??? Weird. Did you already try a fresh install of EQ just for this account?
Not yet. As I posted elsewhere, I assumed that since the other accounts loaded normally on the same install, that it must be a config issue. I think a reinstall might be the next step, although logically that shouldn't make a difference.
 

Users who are viewing this thread

Top