• You've discovered RedGuides 📕 an EverQuest multi-boxing community 🛡️🧙🗡️. We want you to play several EQ characters at once, come join us and say hello! 👋
  • IS THIS SITE UGLY? Click "RG3" at the very bottom-left of this page to change it. To dismiss this notice, click the X --->

Problem - Login requires valid everquest subscription (1 Viewer)

Joined
Aug 16, 2017
RedCents
50¢
I made a few new accounts last night and when I try logging in I am greeted with this.
1619769115152.png
Accounts were made with their own email address which too were freshly made. I can login through the website but no luck logging into everquest world. Has anyone else had this message appear? I did a quick search so if I missed the post my appologies. Will await a bit for some insight. I have not verified the emails on these accounts either which I will do here shortly if I cant find any light at the end of the tunnel. Thanks!
 

Sic

Moderator
Joined
May 5, 2016
RedCents
13,257¢
Likely need to verify the email as you mentioned. It is part of the character account creation process
 
Last edited:
Joined
Aug 16, 2017
RedCents
50¢
We could by-pass the email verification by using mq2login or changing the eq directory target before. I know this worked a month ago with the last batch of toons I made. I just went to verify the email using the link daybreak sent
1619776861865.png
This is the message followed
1619776884204.png
lol new company procedures?

EDIT : checked some other accounts I attempted to setup last night all met with the above ^^^
1619783288889.png
Seems as if they are enforcing secret questions being set possibly to crack down on account sales? Just my thought as I try to figure out other possibilities. I setup the secret question and was still unable to verify with the email used to create the account so I used another email I setup last night for one of the other accounts. I was able to get that email verified so I went to log into EQ and now this is back.
1619783732386.png
 
Last edited:
Joined
Aug 12, 2018
RedCents
558¢
Numerous others have mentioned email verification issues on the "other" forums. It would help the count if you could go there and click like on the first post so they know how big the problem is.

And maybe add this new error about a valid subscription.

 
Joined
Aug 16, 2017
RedCents
50¢
I finally got to login after trying different variations.
1) verify email - didn't work
2) set secret question - didn't work
3) verify email and set secret question - didn't work
4) setup new account, run the launcher, no email verification, no secret question set. A pop-up saying you need to verify email. Close launcher use mq2login or patchme to bypass the launcher. - worked
I'm not sure what or when caused this to happen but this wasn't a thing last month. Hopefully this will help others who run into this problem when trying to keep a "clean account"
 
Joined
Oct 26, 2020
RedCents
854¢
I finally got to login after trying different variations.
1) verify email - didn't work
2) set secret question - didn't work
3) verify email and set secret question - didn't work
4) setup new account, run the launcher, no email verification, no secret question set. A pop-up saying you need to verify email. Close launcher use mq2login or patchme to bypass the launcher. - worked
I'm not sure what or when caused this to happen but this wasn't a thing last month. Hopefully this will help others who run into this problem when trying to keep a "clean account"
Happened to me when i created the 6th account associated with an e-Mail. The first 5 worked fine, they may have implemented some sort of limit/control
 
Joined
Aug 16, 2017
RedCents
50¢
all of my attempts were with new email accounts made minutes before making a daybreak account. I made some on my pc and then made some more on my phone thinking maybe it was a IP prevention as some of you have stated. I have made 8 different accounts in the past 30ish hours and they have all been unable to login when trying to bypass the launchpad. I seen some others were having silimar problems but a different message, I havnt seen any posts about requiring a valid eq subscription it has been many years since a subscription was required to be able to login the game, maybe this new TLP has something to do with it? IDK for now im happy as I found a way to get logged in but I am interested if anyone figures out whats going on behind this. Thanks for the input guys!
 
Joined
Oct 26, 2020
RedCents
854¢
Just a heads up - ISP - there are no clean accounts now. Did you change your VPN for every email?
Me? Nah...i just made a new gmail, did 5 accounts...then said...you know what maybe a bard...and of course it wouldn't let me do the 6th one for the bard. I do change my VPN daily though...but i tried a 6th the following day from a different location via vpn and it was jinxed already. Wouldn't let me verify using the same e-Mail
 
Joined
Dec 8, 2020
RedCents
30¢
I just went through creating some new accounts and thanks for the tips in this thread. Here are the 2 fixes that I needed to do:

1.) Change your account email if unable to validate via the original 'verify now' link (original gmail failed to validate, changed it to another gmail and went through immediately)
2.) Use the base LaunchPad client and 'Log into account' there first. (original launcher via mq2login matched the thread creators screenshots)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top