• IS THIS SITE UGLY? Click "RG3" at the very bottom-left of this page to change it. To dismiss this notice, click the X --->

Problem - Attack Turning Off on Target Switch

Joined
Jul 15, 2019
Likes
13
RedCents
131¢
#1
Hello Everyone,

I looked and looked and can't find a solution to this problem. I use an SK as a main and like to dot each target when pulling large groups and it is extremely irritating that attack turns off every single time I switch targets. I also switch targets when I need to grab aggro fast when I can't use an AE spell like in GMM for instance where you are surrounded by friendlies that will add and give no exp if you hit/taunt them. Many times I don't notice it and stand there like an idiot not swinging at all. /assist on does nothing (mine was set that way anyway). I played around with settings and can't figure out how to leave attack on when switching targets. I also can't find a way to add Spurn to the auto commands. Withstand is lvl 83 and I stopped using it at lvl88. I box 2 SK and have to multibind to get some of these things to work.

Otherwise overall loving it. These two things however are irritating the crap out of me where sometimes I /unload on my main and even alt tab once I am to camp which means I need to reload and start crap to move unless I want to use the craptastic /fol built into EQ. Thanks!
 
Joined
Jun 18, 2014
Likes
251
RedCents
3,843¢
#2
Both of your issues are a mq2melee settings. Unless you are running a macro. I will see if I can find the settings later
 
Joined
Apr 4, 2015
Likes
18
RedCents
251¢
#3
im Pretty sure it’s kiss that turns off when switching targets it also turns /assist off at very beginning just /pause 30,/assist ON in the startup hotkey
 
Joined
Jul 15, 2019
Likes
13
RedCents
131¢
#4
It happens regardless if I am using Kiss or not. I haven't used Kiss much yet as I am PLing 3 new toons but plan to once they are high enough level. Right now they would just run in and die. As soon as I run MQ2 it turns off when switch targets. If there is a setting to change it that would be awesome. My new toons so are just being dragged around and I love the follow me button. That works about 95% where the /fol works about 5% so it's a huge improvement. I do wish it would let you take over a toon that has their face buried in a wall without going back to the leader, turning off follow me, going back to the stuck toon and fixing them, then going back to LDR and hitting the button again for sometimes 5 toons that found a wall or a tree. If there is a setting to let you take over for a sec and then they go on their merry way that would be great to know. I have no idea why you would want to turn off attack just because you switched targets while fighting. Maybe if you switched to a mezzed mob? I normally kill the unmezzed ones first so even then. I am pretty new to this and none of the guides I have read even mentioned this. The stick range thing almost caused a wipe in Wending Ways during the fire boss. Couldn't drag the guy to the next fire pot. That was a surprise for sure. Good thing I have 2 SK because the first one died while I was trying to move the mob around. I turned that off on everyone since it just causes issues for me in that mission. I have had toons "stuck" while not facing the mob and it wouldn't let me reposition them. Other times it worked perfectly. I plan to mess with the settings later and see if I can get that working better. The big thing is the attack turning off. Almost makes it unplayable when I have more than 1 mob which is basically every fight that isn't a boss fight. I try to swarm kill until I die then I pull 1 less mob the next time.
 
Joined
Apr 4, 2015
Likes
18
RedCents
251¢
#5
I found a quick fix for the follow problem was to just hit the “follow key” again with the toon that ur wanting to follow away from the rock/wall with a clean LOS to the stuck toons. It should refresh path and line back up to follow

Least that’s how it works for me with /afol
 
Joined
Mar 9, 2017
Likes
729
RedCents
8,473¢
#6
MQ2Melee defaults: Attack stuff sounds like mq2melee plugin. If you're not running any macros, it has to be an auto-loading plugin.

Try these in-game commands. This one should show your current MQ2melee settings:
Code:
/melee
Then adjust these settings as you'd like
  • stickbreak=1 will let you move your toon during combat, instead of "lock-on" mode.
  • stickrange=0 will turn the "stick" in combat feature off
Code:
/melee stickbreak=1
/melee stickrange=0 
/melee save
You can look up all your custom plugin settings in your server_name.ini in your Release folder. Here is the mq2melee wiki and settings info page.

Spurn via mq2melee: Yeah withstand= is the correct settings, but I think mq2melee may not have been updated to include Spurn, the ability after Repel. Most tanks running KA include a DPS |Mash line for spurn to make KA handle it.

MQ2melee can do holy/downs though and those can fire Spurn. You could add this line to your server_name.ini in the MQ2Melee section (as noted above) to make it run Spurn during fights:
Code:
holyflag0=1
holyshit0=/if ${Me.CombatState.Equal[COMBAT]} && ${Me.CombatAbilityReady[Spurn]}  /disc spurn
 
Joined
Jun 18, 2014
Likes
251
RedCents
3,843¢
#8
Spurn is in there just like all abilities it snap shots what you have when you make your mq2melee settings you can adjust the withstand to be spurn by taking all you settings out and saving them to another file and the melee save and melee load and it will populate to your current withstand
 
Joined
Jul 15, 2019
Likes
13
RedCents
131¢
#10
Spurn is working now. Thank you all for the help. Still wishing attack didn't turn off on target switch. Makes no sense as to why that is the only setting. If you ever main an SK you would know why you would want attack to stay active when switching targets. Trying to figure out how to get bite to fire automatically next.
I am getting some weird error about rez commands being old and I can't find any info on wtf it is talking about or how and what to update.
 
Joined
Mar 21, 2014
Likes
284
RedCents
11,972¢
#12
Spurn is working now. Thank you all for the help. Still wishing attack didn't turn off on target switch. Makes no sense as to why that is the only setting. If you ever main an SK you would know why you would want attack to stay active when switching targets. Trying to figure out how to get bite to fire automatically next.
I am getting some weird error about rez commands being old and I can't find any info on wtf it is talking about or how and what to update.

There is a good reason for turning off attack when switching targets. The #1 reason is, what if you target a friendly NPC by accident. There are time you will have to fight side by side friendly NPC, and if you attack one, then all your friendly NPC's just became enemies.
 
Joined
Jul 15, 2019
Likes
13
RedCents
131¢
#13
I am not targeting by clicking mobs, I target by going down the extended target list. If it is on my extended target list it already isn't friendly. Also, with this turning off I now have a delay before it lets me hit attack again. Only about a half a second but that adds up when you have 20 or more mobs on you.
 
Joined
Mar 21, 2014
Likes
284
RedCents
11,972¢
#14
Make Sure you are not using MQ2melee. Melee will turn off attack if you switch targets. Your target can be set for you, by the first mob that hits you. So if your target is clear and there is a mob that is NOT mezzed and it hits you, that is your new target. If you then click on an XTarget entry, that is NOT your current target, then you just switched targets.
 
Top